Ubuntu Touch, or a Waste of a Perfectly Good Phone

So Ubuntu released their latest version, Sloppy Salpinx or something to that effect. It’s a big deal because it’s also the first stable version for the phone. Right now they only support the Nexus 4 and the Galaxy Nexus…which is handy, because I have a Galaxy Nexus I’m not using.

And now that I’ve installed it, that’s ok, because I won’t be using it for this, either.

The boot screen is black. Just black. You don’t know that it’s loading at all. Once you realize it’s up, it’s horribly laggy on the Galaxy Nexus. It guides you through its interface, which is theoretically straightforward. Swipe in from the left to get the App bar and a Start button, swipe from the right to swap active applications. Problem is, it turns out it’s not so straightforward.

Take the Network settings, for example. Big plus for Ubuntu, if you swipe down for the notifications tray, if your finger’s on a specific item, like the wireless icon, or email, it’ll show you that specific option. Great idea. Love it.

Now try to join a WPA2 Enterprise network. Check mark. And uh, no prompt for login. Check for documentation. And there isn’t. So…what exactly do I do? Oh, here’s the wiki, and it says that I should connect the device, edit a wpa_supplicant.conf and copy that over via USB and oh dear I’ve gone crosseyed.

Maybe there’s something in the network settings. So I go to Network. There’s no options. There must be other options, right? I’ll just hit the Back button. No Back button. Where the hell? I’ll just…see here, and…oh, I can swipe up from the bottom? Great. There’s a Back button. And there’s settings! Everywhere!

“About this Phone” sounds good. Tap. Wait. Nothing. Tap again. OH HOLY CRAP, WHERE ARE YOU GOING WHY AM I IN STORAGE? BACK BUTTON! wait swipe up from bottom, back button, About This Phone! Which has a Storage button to click right where it was on the previous Settings menu.

Hey, I’m still not connected to the network, why…oh. Wifi’s off. At least it’s “x” on the notifications-settings-menu-tray-thing. And if I need a tray, I’ll have the penne alla arrabiata. </izzard> But maybe it just wants a non-Enterprise network. I’ll connect to our Visitor wireless. Blip, bloop…and uh, there’s a white bar over the antenna, and a grayer-one, where there were two greyer-ones before, so I assume I’m…connected?

Fire up the Browser and nothing. But I get a pretty screen that says “I see you’re having trouble connecting to <url-of-visitor-wireless-redirector-and-login-screen>. You should make sure you’re online!” so that’s a wash. Fire up a hotspot on my Note 2 and now I’m connected. On the third try, because it tried to reconnect me to the Visitor Wireless.

And I try Facebook in the Browser app, and it says “Install our Android app for a better experience.”

Sigh.

Leave a Reply

Your email address will not be published. Required fields are marked *